Починаючи з релізу Firefox 55, плагін Adobe Flash для Firefox буде за замовчуванням запитувати дозвіл у всіх користувачів перед запуском.

Раніше, в серпні 2016 року, Mozilla попереджала про це в рамках відмови від плагінів, створених за технологією NPAPI.

Firefox 55 будет запрашивать разрешение на использование Flash по умолчанию

В даний час Flash є єдиним плагіном NPAPI, який як і раніше підтримується в Firefox, і зміна налаштувань за умовчанням «Завжди включати» на «Включати за запитом» — це всього лише ще один крок до завершального етапу повного припинення підтримки Flash.

Нова настройка Flash за замовчуванням вже доступна в Firefox Nightly Edition і буде включена в альфа-версії і бета-версії релізу версії v55 Stable, до якої Firefox поступово наближається.

Це говорить про те, що Firefox опосередковано заохочує використання HTML5 замість Flash для всього мультимедійного контенту.

Інші браузери, такі як Google Chrome, Brave або Opera, вже вимагають підтвердження при запуску Flash або за замовчуванням його вимкнули.

Крім того, починаючи з Firefox 55, Mozilla заборонить Flash завантажувати контент з будь схемою URL, крім HTTP і HTTPS. Це означає, що Flash не буде завантажувати та відтворювати локальні файли, а також файли, отримані по FTP або іншим протоколам. Mozilla заявила, що це поліпшення безпеки — крок вперед для запобігання експлойтів браузера.

Mozilla планує випустити Firefox 55 8 серпня 2017 року, судячи з плану релізів на MozillaWiki.

Джерела:

ITHelpblog.pro

tproger.ru